#419 - Add support for https://
Type Enhancement
Status Completed
Milestone 3.5.1
Version -
Component -
Priority Highest
Severity Major
Assigned to Jack
Reported 8 years ago
Updated 8 years ago
Votes 0
Related tickets
Proposed time
Worked time

It's actually impossible to run Traq in secure mode via https://

If I enable https://, all the query and links in traq have an https:// url but it looks like there is a redirection to a non https:// mode

Ticket History

8 years and 4 months ago by Jack

  • Status New Investigating

Where does this redirection from https to http take place?

When clicking the link(s) or during form submission?

8 years and 4 months ago by Michel LAURENT

After checking again, I founded that the problem only occurs in Safari on my mac. The problem is not a redirection but a not completely safe connection through https:// due to news plugin not using an https:// connection (http://traq.io/news.json).

[Warning] The page at https://**** ran insecure content from http://traq.io/news.json?callback=jQuery1110034150170045904815_1397062615646&_=1397062615647.

8 years and 4 months ago by Jack

  • Severity Normal Major
  • Priority Normal Highest
  • Status Investigating Accepted
  • Assigned to Jack

Ah, yes. I will have to fix that, either by disabling the fetching of news when accessing the AdminCP via https or setting up https on Traq.io

Jack closed as Completed 8 years and 4 months ago