#425 - Relative links incorrect on main page in Wiki
Type Defect
Status Completed
Milestone 3.5.1
Version 3.5
Component -
Priority Normal
Severity Normal
Assigned to Jack
Reported 8 years ago
Updated 8 years ago
Votes 0
Related tickets
Proposed time
Worked time

What did you do to cause this?

Create a main wiki page with a relative link to another wiki page, e.g. page2

Now create page2

If you now open the main wiki page by clicking Wiki in the main menu, the link to page2 is projectname/page2, which is incorrect.

What page were you on?

projectname/wiki (bad) and projectname/wiki/main (good)

What PHP and MariaDB versions do you run?

PHP5.4 and MySQL (sorry...) 5.5 ;-)

Describe the defect:

If you just click Wiki, then the path-segment 'wiki' is missing in the relative links to other wiki pages. (projectname/page2)

If you click >Wiki >Pages >Main

then the links are correct: projectname/wiki/page2

The problem is just that the same page is displayed with 2 different urls, without correcting the links. Always displaying it in the same location would already solve the issue.

Ticket History

8 years and 2 months ago by Jack

  • Status New Accepted
  • Assigned to Jack

This is because there is no real way to do relative wiki links, the [page2](page2) format is Markdown.

But I will be adding a relative wiki linking format.

Jack closed as Completed 8 years and 2 months ago