Jump to content


Click here to lend your support to: Traq and make a donation at pledgie.com !
Photo

Message: No input file specified.


  • Please log in to reply
4 replies to this topic

#1 ebiz98

ebiz98

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 November 2011 - 05:57 AM

I am attempting to move my traq v2.2 from my local development box into a 3rd party hosted environment (Linux) where I cannot change Apache settings. I ftp'd all of the files, backup and restored, the DB, changed my db settings in config.php and it looks like it all worked fine...

I get the landing page with my projects, but when I click on any of the project links I get the message:

No input file specified.

I am sure I need to adjust some setting...

Many Thanks!


#2 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 17 November 2011 - 05:10 PM

Try updating the .htaccess file with the following lines and see if that works.

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php/$1 [L]


#3 ebiz98

ebiz98

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 November 2011 - 05:52 PM

UPDATE: The ADMIN section (http://bugtrack.35notes.com/admincp/ ) works like a champ, but the user section does not work, and it gives me
the error: No input file specified.

Also I have looked at changing the config.php and .htaccess but neither worked.
http://codeigniter.c...stallaton_Tips/
http://www.pankajdan...ed-codeigniter/

Unfortunately NO LUCK. Any help would be appreciated!



#4 ebiz98

ebiz98

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 November 2011 - 06:53 PM

Thanks Jack!

Tried it but unfortunately there was no difference.. .
As mentioned in the update, the admin side works really nice...

Any other ideas? I am searching the web for others with similar issues with GoDaddy Lunix hosting as well... It's got to be a easy thing I am missing... :-)

 
UPDATE: PROBLEM SOLVED!

It was a GoDaddy.com configuration setting! --
Basically needed to change the .php file extension setting
from: PHP 5.x FastCGI
To: PHP 5.2x

I reverted back to the original .htaccess (not the one above)

(Found my answer here: http://www.cesgeekbo...ed-godaddy.html )

Anyhow - it is now documented for future generations :-)
Thanks Jack!




#5 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 18 November 2011 - 03:30 AM

Glad you got it solved :)


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users