Jump to content


Click here to lend your support to: Traq and make a donation at pledgie.com !
Photo

Post-Install Error: He's dead, Jim! The requested page '/username/traq/register' couldn't be found.


  • Please log in to reply
15 replies to this topic

#1 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 09 February 2014 - 12:30 AM

After clean install of 3.4.2, I get the "He's dead, Jim!" error.

 

 

Can't figure this one out.

mod-rewrite is enabled, htaccess.txt is now .htaccess

when I click on 'login' or 'register' I get 'He's dead, Jim' error.

 

I get 'He's dead, Jim' error also when I try to login at '/username/traq/admin'

error: "He's dead, Jim The requested page '/username/traq/login' couldn't be found."

 

I expect this is a mod-rewrite issue. But, I can't be sure.

I've been tweaking the .htaccess

 

any advice?



#2 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 09 February 2014 - 01:27 AM

What software, including the version, is the server running?



#3 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 09 February 2014 - 02:10 AM

Hi Jack,

Thanks for the reply. 

 

Apache/2.2.3 (Red Hat)

PHP 5.3.

MySQL 5.0.95



#4 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 09 February 2014 - 02:44 AM

all running on Red Hat Enterprise Linux Server release 5.8 (Tikanga)



#5 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 09 February 2014 - 04:11 AM

Would you mind running this in the same directory as Traq's "index.php" with the original ".htaccess" and either posting or private messaging me the output?

<pre>
<?php
foreach ($_SERVER as $key => $value) {
    if (!preg_match("/^(HTTP_|SERVER_|REQUEST_TIME|REMOTE_PORT|REMOTE_ADDR|PATH)/", $key))    {
        echo "{$key} => {$value}" . PHP_EOL;
    }
}

What this code will do is output some information about the request such as the request path, script path, query string and a few other things.



#6 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 09 February 2014 - 08:46 AM

Here's the output

DOCUMENT_ROOT => /var/www/html
SCRIPT_FILENAME => /var/www/html/username/traq/test_traq.php
GATEWAY_INTERFACE => CGI/1.1
REQUEST_METHOD => GET
QUERY_STRING => 
REQUEST_URI => /username/traq/test_traq.php
SCRIPT_NAME => /username/traq/test_traq.php
PHP_SELF => /username/traq/test_traq.php


#7 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 09 February 2014 - 09:08 AM

Looks good. Does Apache's "httpd.conf" have "AllowOverride" set to "All" or "None" for the document root?



#8 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 09 February 2014 - 09:30 AM

It appears to be set to "All"

 

DOCUMENT_ROOT => /var/www/html

Here's a snippet from httpd.conf

<Directory "/var/www/html">

                     .   .   .
#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride All

                     .   .   .

</Directory>


#9 Jack

Jack

    Project Founder

  • Administrators
  • 673 posts
  • LocationAustralia

Posted 10 February 2014 - 04:52 AM

What variants of the ".htaccess" file have you tried so far?



#10 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 10 February 2014 - 08:15 AM

I don't recall what I tried.  I'm not really familiar with apache mod_rewrite scripts.  I'm reading up about it, using this as a possible learning experience, a trial and error approach.  I've also been manually changing the paths in bootstrap.php

 

again, just a trial and error... I could be bark up the wrong tree here.

// Define the paths needed

define("SYSPATH", dirname(__FILE__) . '/avalon');

define("APPPATH", dirname(__FILE__) . '/traq');

define("DOCROOT", dirname(dirname(__FILE__)));

I've double checked to see that mod_rewrite is actually working correctly on the server.  A simple example worked as expected.  So, it's functioning...

At this point all I can think of is a clean install of Traq.  In the next few days I'll be installing a PHP framework "CakePHP".  Cake also uses mod_rewrite for 'routes' etc.  I'll see how that goes. 

 

Thanks again Jack, for the assistance.



#11 shazbell

shazbell

    Member

  • Members
  • PipPip
  • 11 posts

Posted 12 February 2014 - 07:07 PM

Hello All, 

I just installed Traq and ran into the same issue. What worked for me was to copy all contents of the "upgrade" folder to the application root. I'm using WAMP on Windows. So, I pasted contents of upgrade directory into the www folder.

 

Hope this helps!



#12 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 13 February 2014 - 08:34 PM

@shazbell

 

Thanks for the input.  I'm not seeing an "upgrade folder" in Traq's directory tree.  This is the 3.4 branch of Traq on github.

 

https://github.com/nirix/traq/tree/3.4

 

I'm at a lose at this point.  If anyone had to modify their .htaccess file to get Traq to play nice, can you post it here?

Cheers!



#13 shazbell

shazbell

    Member

  • Members
  • PipPip
  • 11 posts

Posted 14 February 2014 - 09:25 PM

My bad.. I meant the "upload" folder. Here is what I have in the .htaccess file

Options -Indexes
Options +FollowSymLinks
ErrorDocument 404 /index.php
DirectoryIndex index.php index.html index.htm
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteBase "/"
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]
</IfModule>


#14 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 16 February 2014 - 07:10 PM

Now we're talkin',  I have an "upload" directory.  I'll give that a try.  Thanks for posting your .htaccess file, that could come in handy.



#15 jeronimo

jeronimo

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationJapan

Posted 16 February 2014 - 08:05 PM

I've confirmed that I had all contents of "upload" in the application root.  Traq installation directions in INSTALL.txt say

Installing Traq
===============
Installing Traq is quite easy, upload the contents of the `upload` directory
to where you want Traq to be run from on your server.

So, I think shazbell's suggestion and INSTALL.txt are the same. 

 

At this point I'm going to set my Traq installation aside and perhaps try again some time in the future.

Thanks everyone for the help! 



#16 JohnWordsworth

JohnWordsworth

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 April 2014 - 06:25 PM

I've been trying to get Traq up and running for the last couple of hours and this message has been pretty stubbornly standing in my way! I have completed the following procedure, which has resulted in my now seeing "He's dead, Jim! The requested page '/traq/login' couldn't be found." whenever I click on login or register links at the top right of the page or whenever I attempt to login from any of the /admin pages (note that the admin pages show a login form).

 

1. Uploaded the contents of the upload/ folder from the Traq zip to a sub-directory in a new subdomain on our site (bugs.sitename.com/traq/).

2. Went through the install/ process and hooked Traq to our MySQL database.

3. Renamed htaccess.txt to .htaccess.

4. Turned on mod_rewrite - which is definitely working now (before it was going to the plain old 404 error, now it goes to Traq's "He's dead, Jim!" error page.

5. AllowOverride All is enabled under the document directory in the virtual host directive.

 

Server is an Apache 2 server running PHP 5.3.3. Server is running multiple sites which use MySQL and mod_rewrite successfully.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users